跑跑卡丁车手游何时上线在線檢測未來函數

跑跑卡丁车手游贴吧:通達信主力監控系統指標公式

跑跑卡丁车手游何时上线 www.cmaye.icu 來源:Internet,編輯:股旁網,2019-05-22

DRAWRECTREL(0,0,990,990,RGB(20,18,12));
DRAWTEXT_FIX(1,0.14,0.01,1,'股東股份:'),COLORRED;
品種類型:=FINANCE(3);
所屬板塊:=HYBLOCK;
上市天數:=FINANCE(42);
{股總市值:=ROUND(FINANCE(41)/100000000);}
流通盤:=(CAPITAL/1000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股東人數:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.14,0.15,1,'品種類型:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.25,1,'所屬板塊:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.35,1,'上市天數:'),COLORYELLOW;
{DRAWTEXT_FIX(1,0.14,0.45,1,'股總市值:'),COLORYELLOW;}
DRAWTEXT_FIX(1,0.14,0.45,1,'流通盤:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.55,1,'流通市值:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.65,1,'股東人數:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.75,1,'人均持股:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.23,0.25,1,HYBLOCK),COLORLIGREEN;
DRAWNUMBER_FIX(1,0.2,0.35,1,上市天數),COLORWHITE;
DRAWNUMBER_FIX(1,0.19,0.45,1,流通盤),COLORWHITE;
DRAWNUMBER_FIX(1,0.19,0.55,1,流通市值),COLORWHITE;
DRAWNUMBER_FIX(1,0.2,0.65,1,股東人數),COLORWHITE;
DRAWNUMBER_FIX(1,0.2,0.75,1,人均持股),COLORWHITE;
DRAWTEXT_FIX(品種類型=1,0.23,0.15,1,'滬 深 A 股'),COLORMAGENTA;
DRAWTEXT_FIX(品種類型=2,0.23,0.15,1,' 中 小 板'),COLORMAGENTA;
DRAWTEXT_FIX(品種類型=3,0.23,0.15,1,' 創 業 板'),COLORMAGENTA;
DRAWTEXT_FIX(1,0.23,0.35,1,'天'),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.45,1,'億元'),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.55,1,'億元'),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.65,1,'人'),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.75,1,'股'),COLORCYAN;
DRAWTEXT_FIX(1,0.326,0.01,1,'業績指標:'),COLORRED;
凈資收益率:=(FINANCE(33)/FINANCE(34)*100);
銷售毛利率:=CONST(((FINANCE(20)-FINANCE(21))/FINANCE(20)*100));
凈利潤比率:=(FINANCE(30)/FINANCE(20)*100);
主營利潤率:=(FINANCE(23)/FINANCE(20)*100);
優質資產率:=((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19));{理論上越大越好但不同行業有不同標準};
現金負債比:=(FINANCE(25)/FINANCE(15));{缺長期負債或負債總額,理論上越大越好但不同行業有不同標準};
凈利同增率:=FINANCE(43);
總市值(億):FINANCE(41)/100000000,NODRAW; 凈資產:FINANCE(34),NODRAW;
銷凈利率:FINVALUE(199),NODRAW; 凈利潤(萬):FINANCE(30)/10000,NODRAW; 凈利增長率:=FINVALUE(184),NODRAW;
DRAWTEXT_FIX(1,0.34,0.15,1,'凈資收益率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.25,1,'銷售毛利率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.35,1,'凈利潤率 :'),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.45,1,'主營利潤率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.55,1,'優質資產率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.65,1,'現金負債比:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.75,1,'凈利同增率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.4,0.15,1,凈資收益率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.25,1,銷售毛利率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.35,1,凈利潤比率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.45,1,主營利潤率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.55,1,優質資產率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.65,1,現金負債比),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.75,1,凈利同增率),COLORWHITE;
DRAWTEXT_FIX(1,0.498,0.01,1,'財務指標:'),COLORRED;
市凈率:=CONST(DYNAINFO(7) / FINANCE(34));
市銷率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
{每股收益季:=CONST(FINANCE(33)/(5-FINANCE(37)));}
每股收益:=CONST(FINANCE(38));{最近一期}
每股現金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公積金:=CONST(FINANCE(18));
市盈率:=CONST(C/FINANCE(33));
{毛利率:=CONST(((FINANCE(20)-FINANCE(21))/FINANCE(20)*100));}
DRAWTEXT_FIX(1,0.51,0.15,1,'市凈率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.25,1,'市銷率:'),COLORYELLOW;
{DRAWTEXT_FIX(1,0.51,0.35,1,'每股收益季:'),COLORYELLOW;}
{DRAWTEXT_FIX(1,0.51,0.35,1,'毛利率 :'),COLORYELLOW;}
DRAWTEXT_FIX(1,0.51,0.45,1,'每股收益:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.55,1,'每股現金流:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.65,1,'每股未分配:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.75,1,'每股公積金:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.35,1,'市盈率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.57,0.15,1,市凈率),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.25,1,市銷率),COLORWHITE;
{DRAWNUMBER_FIX(1,0.57,0.35,1,每股收益季),COLORWHITE;}
DRAWNUMBER_FIX(1,0.57,0.45,1,每股收益),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.55,1,每股現金流),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.65,1,每股未分配),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.75,1,每股公積金),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.35,1,市盈率),COLORWHITE;
{DRAWNUMBER_FIX(1,0.57,0.85,1,毛利率),COLORWHITE;}
主力籌碼估算:=EMA(WINNER(CLOSE)*70,3),NODRAW,LINETHICK0;
散戶籌碼估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;
散戶套牢比率:=散戶籌碼估算/(主力籌碼估算+散戶籌碼估算)*100,NODRAW;
主力控盤比率:=主力籌碼估算/(主力籌碼估算+散戶籌碼估算)*100,NODRAW,LINETHICK0;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.07,0.88,0,'■ 主力籌碼估算:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.22,0.88,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.17,0.88,0,主力籌碼估算),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.35,0.88,0,'■ 主力控盤比率:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.50,0.88,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.45,0.88,0,主力控盤比率),COLORRED;
{風險系數}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公積用資本公積金代替}
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺長期負債或負債總額}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
DRAWTEXT_FIX(1,0.85,0.01,1,'財務預警:'),COLORRED;
DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,' ●重 警●'),COLORLIRED;
DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,' ○輕 警○'),COLOR0099FF;
DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,' ◎無 警◎'),COLORLIGREEN;
LC:=REF(CLOSE,1);
WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
獲利籌碼:=CONST(WINNER(C)*100);
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能飽和:=(IF(SAT>1,1,SAT)*100);
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活躍:=(WRSI-WR10);
活躍度比:=IF(活躍>=0,(活躍+100)/2,100-ABS((活躍-100)/2));
DRAWTEXT_FIX(1,0.74,0.15,1,STRCAT(STRCAT('量能飽和: ',CON2STR(量能飽和,2)),'%')),COLORYELLOW;
DRAWTEXT_FIX(1,0.74,0.35,1,STRCAT(STRCAT('活躍度比: ',CON2STR(活躍度比,2)),'%')),COLORYELLOW;
DRAWTEXT_FIX(1,0.74,0.55,1,STRCAT(STRCAT('獲利籌碼: ',CON2STR(獲利籌碼,2)),'%')),COLORYELLOW;
DRAWRECTREL(970,340,580,270,RGB(150,10,250));
DRAWRECTREL(970,470,580,540,RGB(150,10,250));
DRAWRECTREL(970,670,580,740,RGB(150,10,250));
DRAWRECTREL(970,340,580+CONST(量能飽和*(970-580)/100),270,RGB(0,100,0));
DRAWRECTREL(970,470,580+CONST(活躍度比*(970-580)/100),540,RGB(0,100,0));
DRAWRECTREL(970,670,580+CONST(獲利籌碼*(970-580)/100),740,RGB(0,100,0));
{DRAWTEXT_FIX(1,0.96,0.01,1,'大盤趨勢:'),COLORRED;
DRAWTEXT_FIX( CONST(INDEXC) >SAR(4,2,20),0.95,0.16,1,'∧向上∧'),COLORRED;
{DRAWTEXT_FIX( CONST(INDEXC) >SAR(4,2,20),0.95,0.11,1,'∧∧∧∧'),COLORRED;}
{DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.16,1,'∨向下∨'),COLORGREEN;
{DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.11,1,'∨∨∨∨'),COLORGREEN;}
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.79,0.90,0,'財務數據日期是第:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.95,0.90,0,' 季度 ■ '),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.93,0.90,0,FINANCE(37)),COLORRED;
DRAWTEXT_FIX(1,0.58,0.78,0,FGBLOCK),COLORLICYAN;
{-----優秀-------}
ER1:=凈資收益率>=13.58;
ER2:=主營利潤率>=22.4;
ER5:=凈利潤比率>=19.42;
SAX1:=每股收益>=0.175;
SAX4:=每股未分配>=2.57;
SAX5:=每股公積金>=3.53;
DP3:=銷售毛利率>=49.13;
ZL:=IF((EMA(WINNER(CLOSE)*70,3))>41 AND ISLASTBAR,1,0);
優秀:=ER1 AND ER2 AND ER5 AND SAX1
AND SAX4 AND SAX5 AND DP3 AND ZL ;
DRAWTEXT_FIX(1,0.97,0.01,1,'基本面評估:'),COLORRED;
DRAWTEXT_FIX(優秀 AND ISLASTBAR,0.95,0.11,1,'優秀'),COLORYELLOW;
{較好}
ER12:=凈資收益率<13.59 AND 凈資收益率>6.23;
ER22:=主營利潤率>=8.34;
ER52:=凈利潤比率>=7.31;
SAX12:= 每股收益>=0.061;
SAX42:=每股未分配>=1.185;
SAX52:=每股公積金>1.62;
DP32:=銷售毛利率>=28.68;
ZL1:=IF((EMA(WINNER(CLOSE)*70,3))>=11.26 AND ISLASTBAR,1,0);
{ER42:=主營業增長率>1; SAX22:=每股凈資產>0.2; DP42:=換手率>0.5; WMF12:=量比>0.5;}
較好:=ER12 AND ER22 AND ER52 AND SAX12
AND SAX42 AND SAX52 AND DP32 AND ZL1;
DRAWTEXT_FIX(較好 AND ISLASTBAR,0.95,0.11,1,'較好'),COLORYELLOW;
{指標偏低}
ER偏低:=凈資收益率<=0.27;
ER2偏低:=主營利潤率<=-1.27;
ER3偏低:=凈利潤比率<=0.34;
SAX偏低:=每股收益<=0.002;
SAX2偏低:=每股未分配<=0.26;
SAX3偏低:=每股公積金<=0.39;
DP偏低:=銷售毛利率<=4.2;{排名后100}
ZL偏低:=IF(((EMA(WINNER(CLOSE)*70,3))<2.81 AND ISLASTBAR),1,0);
偏低:=IF((ER偏低 OR ER2偏低 OR ER3偏低 OR SAX偏低
OR SAX2偏低 OR SAX3偏低 OR DP偏低 OR ZL偏低) AND ISLASTBAR=1,1,0) ;
DRAWTEXT_FIX( 偏低 AND ISLASTBAR=1 ,0.97,0.23,1,'有些指數偏低'),COLORYELLOW;
{一般};
一般:=IF((較好!=1 AND 優秀!=1 AND ZL偏低!=1 AND ISLASTBAR=1),1,0);
DRAWTEXT_FIX(一般 AND ISLASTBAR=1,0.95,0.11,1,'一般'),COLORYELLOW;

通達信主力監控系統指標公式

 

相關文章